Скрыть объявление

Добро пожаловать на наш форум, уважаемые друзья! Регистрируйтесь и переходите в группу "Местный" для того чтоб иметь все привилегии на форуме, удачи вам:)

[PW] Серверная 1.2.6 Сборка Perfect World 1.2.6

Тема в разделе "[PW] Серверная", создана пользователем Andrey, 30 апр 2015.

  1. Andrey
    Оффлайн

    Andrey Я админ,смекаешь? Команда форума Администратор Модератор Проверенный Местный Пользователь

    Регистрация:
    18 апр 2015
    Сообщения:
    1.709
    Симпатии:
    729
    1: Сервер вынесен в директорию /jbox/
    2: Временные файлы сервера хранятса в директории /jbox/tmp/
    3: Все конфиги очищены от мусора.
    4: Настроены фильтры имён персонажей, названий гильдий. Баго ники не пройдут.
    5: Файлы фильтров теперь называется filters.conf
    6: Во всех конфигах установлены адреса 127.0.0.1
    7: Пофикшен дюп. (не скажу как).
    8: Должна работает свадьба но сам не проверял.
    9: Изменен скрипт запуска сервера. Загрузка сервера занимает примерно 5 секунд.
    10: Изменён скрипт остановки сервера. Остановка моментальная + очищаетса кеш памяти.
    11: В директории /jbox/zscripts лежит файл для чисти логов. Ипользование (выполняйте только когда сервер выключен): /jbox/zscripts/clearlogs start
    12: Авто бекап gamedbd, uniquenamed и базы mysql делается каждые 8 часов. Не забывайте периодически удалять лишние бекапы. /jbox/backup/
    13: Auth пофикшен от падения + из него удалён весь мусор.
    14: Карта мира обрезана дабы игроки не могли попасть на кладбище нпц.
    15: Для запуска айвеба используйте скрипт /jbox/iweb. Пример: /jbox/iweb start и /jbox/iweb/stop
    16: Настроен Firewall. Настроена защита от не большого ддоса/флуда + все лишние порты полностью закрыты от посторонних.
     
    Zevs, Klotis и Bum4ik нравится это.
  2. Mntz
    Оффлайн

    Mntz Новый участник Пользователь

    Регистрация:
    16 окт 2018
    Сообщения:
    2
    Симпатии:
    0
    Какая должна быть версия клиента для этой сборки? Я пробовал и 1.2.6 и 1.3.4, ни с одной из них сервер не хочет работать. На клиенте 1.3.4 пишет "Старая версия клиента", при попытке поднять версию в /server/glinkd/gamesys.conf долгая загрузка и по итогу "Ошибка сети". На клиенте 1.2.6 просто не видит сервер. Все клиенты я качал с вашего сайта.

    Так же проблема с запуском айвеба, ошибка - /opt/tomcat/bin/startup.sh: not found
     
    Последнее редактирование модератором: 2 май 2019
  3. semmi
    Оффлайн

    semmi Новый участник Пользователь

    Регистрация:
    4 апр 2019
    Сообщения:
    9
    Симпатии:
    4
    Zevs нравится это.
  4. Mntz
    Оффлайн

    Mntz Новый участник Пользователь

    Регистрация:
    16 окт 2018
    Сообщения:
    2
    Симпатии:
    0
    Не поверишь, но и их я пробовал - ничего не выходит. Я совсем чайник и наверно что-то делаю не правильно еще на этапе вписывания паролей/айпишников, ведь это не совсем стандартная сборка, некоторых файлов из обычной инструкции по типу /etc/table.xml вообще не найти. В любом случае спасибо, что откликнулся!
     
  5. semmi
    Оффлайн

    semmi Новый участник Пользователь

    Регистрация:
    4 апр 2019
    Сообщения:
    9
    Симпатии:
    4
    Там в комплекте всё есть просто прописать пароль от базы в jbox\mauthd\build\conf\table.xml и свой IP в \jbox\glinkd\gamesys.conf и все файлы раскидать по своим местам (etc,lib и var). В сборке нет IWEB но его тут на форуме можно скачать и настроить (путь к IWEB смотри файл iweb в корне сборки). Запуск самой сборки через mini.sh. А так всё там настроено для запуска.
     
  6. elmon
    Оффлайн

    elmon Новый участник Пользователь

    Регистрация:
    6 июн 2019
    Сообщения:
    1
    Симпатии:
    0
    Та же проблема. Либо не видит сервер, либо ругается на версию. Пробовал разные клиенты.
     
  7. Самвел
    Оффлайн

    Самвел Новый участник Пользователь

    Регистрация:
    28 июл 2019
    Сообщения:
    16
    Симпатии:
    8
    Я поставил, все гуд, только с шопом проблема, не могу свадебные товары добавить и значок маршала призрака, сервер ругается и не впускает как обычно:Fox02:
     
  8. woromania
    Оффлайн

    woromania Новый участник Пользователь

    Регистрация:
    5 окт 2018
    Сообщения:
    2
    Симпатии:
    0
    Как ни странно, но вопрос с клиентскими файлами для этой сборки для меня оказался все еще актуальным. Пробовал файлы для версии 1.2.6 из общей темы по клиентским файлам, но с ними не удается подключиться к серверу, да и статус сервера в списке для подключения не отображается, а с файлами из данной темы авторизуйтесь отдается старая версия клиента. Может кто предоставить действительно работающие клиентские файлы или ткнуть носом, если я что-то упустил?
     
  9. Intrantu
    Оффлайн

    Intrantu Новый участник Пользователь

    Регистрация:
    11 сен 2020
    Сообщения:
    20
    Симпатии:
    2
    Обратитесь в вопросник, описав вашу проблему более подробно: что и как делаете, приложите скрины.
    Еще раз повторяю. В СООТВЕТСТВУЮЩЕМ РАЗДЕЛЕ!
     
  10. woromania
    Оффлайн

    woromania Новый участник Пользователь

    Регистрация:
    5 окт 2018
    Сообщения:
    2
    Симпатии:
    0
    Проблему удалось решить самостоятельно изменив параметр version в файле gamesys.conf и изменив параметры подключения к базе данных в файле table.xml, так как упустил тот факт, что бд сидит в докер контейнере и слушает не совсем стандартный порт (вдруг кто-то еще будет искать решение подобной проблемы), но все же благодарен за стремление помочь в решении проблемы :)
     
  11. Fokys
    Оффлайн

    Fokys Новый участник Пользователь

    Регистрация:
    24 авг 2020
    Сообщения:
    7
    Симпатии:
    2
Похожие темы
  1. Andrey
    Ответов:
    0
    Просмотров:
    2.226
  2. Andrey

    [PW] Гайды Любая версия Gm Panel for Perfect World

    Andrey, 9 окт 2015, в разделе: [PW] Гайды
    Ответов:
    0
    Просмотров:
    3.111
  3. Andrey
    Ответов:
    0
    Просмотров:
    1.021
  4. Andrey
    Ответов:
    0
    Просмотров:
    2.237
  5. Damnes
    Ответов:
    0
    Просмотров:
    616
Загрузка...

Поделиться этой страницей